Sibelius Scorch plugin for IE11

TL;DR – the browser detection on the Sibelius Scorch plugin download page is borked. If you visit that page from IE 11, you’ll get the “netscape” version of the plugin installer, which will fail silently. You’ll need to put IE into IE9 emulation mode (see this article if you don’t know how to do that) and reload the initial download page, the one where you enter your email address. You’ll know you’re on the right track if you see “ActiveX only” in the plugin description.

Longer rant/notes:
With truly exquisite irony, if you search the Sibelius knowledgebase the first thing you’ll find is an article exhorting you to make sure you have the very latest version of your browser. Lol.

Apart from the silliness of a) having a broken detection script and b) evidently not testing properly, Sibelius/Avid are likely to remain unaware of this because there is no way to contact them. You can sign up for their support forums (why would I bother doing that? I don’t need support, I want to offer it), or you can call their support phone number (but have your service contract ready – srsly?). So unless the Scorch devs are devoted followers of this blog, I don’t expect there’ll be a fix anytime soon.

But who cares, I have it on good authority that IE users are “lazy” and “ignorant” so we don’t need to worry about *them*, right? Personally, I only use IE because my customers do and I want to know what their experience is. What a crazy idea that is.

The good news is that the plugin works just fine.

BTW, when I say the “netscape” (that is, Chrome, Safari and Firefox) installer fails silently, I mean it declares that it has completed but it actually does nothing useful for the IE user. It may well work just fine as far as installing the plugins for those browsers. Maybe it even works when launched from IE, which would be a nice (but still useless) trick.

Leave a Reply

Your email address will not be published. Required fields are marked *